Ankündigung

Einklappen
Keine Ankündigung bisher.

Weiterleitung + Letsencrypt / Certbot

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Weiterleitung + Letsencrypt / Certbot

    Stehe gerade etwas mit Fragezeichen da... Ich habe hier eine Domain, die ist aktuell per SSL erreichbar. Die soll nun auf eine andere Domain weitergeleitet werden. So, nun die doofe Frage schon mal, wie stelle ich das an?

    Also die Weiterleitung ist mir schon klar, aber was ist mit SSL?

    Eigentlich wollte ich die so wie früher auch einfach komplett umleiten, der klassische Umzug eben. Aber SSL steht mir da irgendwie gedanklich im Weg. Die alte Domain ist auch von außen verlinkt, also die SSL-Version. Wenn ich die Weiterleitung also so mache wie bisher, dann geht das für die Nutzer - vorerst.

    Wenn dann aber ein Update vom Zertifikat kommt, also vom Certbot, dann schlägt das fehl, denn der braucht als Antwort einen Header 200 und keinen 301. Folge, Zertifikat wird nicht erneuert und irgendwann kommt die Browser-Warnung, dass abgelaufen.

    Lasse ich SSL gleich ganz weg, dann passiert das gleiche.

    Stehe da nun echt auf dem Schlauch. Muss ich etwa das ".well-known" da lassen wo es ist und quasi das Webdir, das ich ja nicht mehr brauche, aufrechterhalten, nur damit das Zertifikat geupdated werden kann? Oder bin ich da gerade auf dem Holzweg?

    Danke!
    Der alte Sack hat gesprochen....

    #2
    Vhost lassen und 301 redirect. Geht auch mit hsts. Wir haben ja ... geredet :)

    wenn etwas möglich erscheint mach ich das, wenn das nicht klappt gehts ans unmögliche und ansonsten das undenkbare.
    Ich denke, also BING ich :)


    Support 24h Bereitschaft 0163 2161604 - NUR Für Kunden von SEO NW! Faires Hosting - Alternative Suchmaschinen

    Kommentar


      #3
      Danke Alex, war wohl auf dem Holzweg. Wenn der Bot 301 folgt und dem dann egal ist, dass das Ziel eine andere Domain ist als für das Zertifikat, dann ist ja alles gut, wusste ich nicht.
      Der alte Sack hat gesprochen....

      Kommentar


        #4
        Möchte noch die Anmerkung schreiben, Alex hatte sie ja schon per Mail. Ist keine Kritik, nur ein Hinweis, denn ich hasse Threads, wo keine Lösung ist. Das von Alex funktioniert nicht, wenn der Certbot das Verzeichnis /.well-known/ im Doc-Root der Domain sucht, was z.B., wenn man das Apache-Modul vom Certbot nutzt, der Standard ist. Denn das ist dann umgeleitet. Der Certbot folgt dem 301, aber er findet das File dort nicht, denn das hat er im Doc-Root von Domain1 abgelegt, nicht unter dem Weiterleitungsziel Domain2.

        Die Konstellation bei Alex ist eine andere. Dort schreibt der Certbot die Auth-Files nicht ins Doc-Root der Domain, sondern in einen globalen Ordner auf dem Server, der dann per "Alias" eingehängt wird. Daher ist es egal, wohin die Domain leitet, der globale Ordner ist der gleiche.

        Also, Lösung: Entweder einen globalen Ordner für den Certbot anlegen und die Zertifikate auch so anfordern oder bei der Domainweiterleitung das Verzeichnis /.well-known/ ausklammern, damit das nicht weitergeleitet wird.
        Der alte Sack hat gesprochen....

        Kommentar

        Lädt...
        X

        Das Rechtliche
        Impressum | Widerruf | Datenschutz | Disclaimer | Links