ahrefs Backlink Checker übernimmt Domain Rating der alten Website nicht

  • Hallo,

    zunächst einmal möchte ich dir danken, dass du so eine Anlaufstelle für SEO anbietest.

    Ich habe auch direkt die erste Frage:

    Ich habe mehrere Forensysteme über mehrere Domains unter Woltlab betrieben. Nach einem Umzug liegt nun alles auf einer Seite, die du leicht über meine Signatur erahnen kannst.

    Eine meiner alten Domains lautet https://newworld-forum.de

    Der ahrefs Backlink-Checker zeigt mir unter https://ahrefs.com/de/backlink-checker folgendes Backlink-Profil an:

    Ich habe folgendes in der .htaccess der alten Domain stehen:

    Apache Configuration
    RewriteEngine On
    RewriteCond %{REQUEST_URI} (.*)
    RewriteRule ^(.*)$ https://mmo-forum.de/board/66-new-world-forum/ [L,R=301]

    Damit werden sämtliche Unterseiten und Hauptseite der alten Domain auf die neue umgeleitet.

    Also dachte ich, dass auch die Linkpower mit übernommen wurde. Wurde sie das denn? Der Umzug ist allerdings erst ca. 3 Wochen her. Vielleicht braucht es noch etwas?

    Ich habe den Test über den ahrefs Backlink Checker also auch für die neue Domain, unter der jetzt alle Projekte jeweils in Unterforen laufen getestet:

    Müssten nicht eigentlich beide Ergebnisse nun identisch sein? Weshalb wird das Domainrating nicht übernommen?

    Ich bin gespannt auf deine / eure Antwort(en).

  • Die werden da sicherlich noch etwas brauchen. Die müssen die 4.4k Links ja erst mal finden und neu bewerten. Wobei ich nun aber nicht weiß, on ahrefs das über den direkten Weg macht oder über die eigentliche Quelle. Denke aber wohl, das geht über die Quelle.

    Also wohl eher nicht "alte Seite 1 hatte einen Link", neu prüfen, 301, neue Seite hat einen

    sondern eher

    Quellseite hat einen Link -> neu prüfen -> alte Zielseite -> 301 -> neue Zielseite.

    Ob die gleich sein müssten?

    Keine Ahnung, das kommt auf die beiden Domänen an und auf die interne Bewertung von ahrefs. Wie man ja unschwer erkennen kann, die alte Domain hatte dort 4.4k Links, die neue 26k. Also entweder zählt da nun was völlig falsch, oder die neue Domain hat mehr links. 1zu1 übernehmen müsste ja zumindest da ansonsten den gleichen Wert haben. Unter Berücksichtigung der Zeit, dann bei der neuen eigentlich einen deutlich kleineren Wert, der neue ist aber größer.

    Und aus dem ganzen und eben auch noch anderen Metriken wird der DR berechnet. Wie genau, keine Ahnung, aber da wird wohl halt wirklich alles einfließen. Also auch die "mehr Links", die ja nicht unbedingt besser sein müssen, als die vorherigen. Einfach nur "mehr" bedeutet ja nicht, dass es besser ist. In der Schule hat man auch nicht automatisch eine bessere Gesamtnote, nur weil man mehr Prüfungen in einem Fach hatte. Meine, es ist durchaus möglich, dass selbst dann, wenn alle 4.4k Links übernommen wurden, der DR immer noch schlechter ist als vorher, weil die fast 20k andere Links dabei sind, die vielleicht den Wert drücken?

    Und es spricht sogar einiges dafür, dass die Links nun schlechter bewertet werden, denn es sind fast 6mal so viele, das aber bei nur 0,5mal der Quelldomänen. Und dann ist das eben wohl noch der 301, den die sicherlich nicht mit 100% bewerten, denn etwas "Verlust" hat der.

    Und wie man aus dem Links der Seite "210316" ja auch erkennen kann, der hat in beiden Bildern ein anderes Ziel. Vorher war es direkt "root", nun ist es ein 301 über eine Unterseite. Vorbei die da wohl noch nicht alle gefunden haben bzw. schon vorher. Denn der 301, den die an anzeigen, ist ja nicht mehr da, sondern die Ziel-URIs wurden schon geändert. Das sind also Daten, von vor der Änderung. Und wenn ahrefs den Link nach dem Donnerstag, aber vor Freitag gefunden hat, dann ist auch die Quelle eine andere, denn am Donnerstag hast Du ja einen neuen Link gesetzt. Also ist die Anzahl auf der Quellseite eine andere. Sollte eigentlich somit auch zu einer anderen Bewertung für diese eine Quellseite führen.

    Wenn ein Mensch nicht um dich kämpft, hat er nur gewartet, dass du gehst. ;(

  • Guten Morgen und danke für deine Antwort. Ich habe natürlich vergessen zu erwähnen, dass aus 7 einzelnen Unterforen nun ein gemeinsames geworden ist. Alle vorherigen Seiten hatten ein Domainrating zwischen 30 und 16. Jede Seite besitzt ein eigenes Backlinkprofil. Und das wird nun auf die neue Hauptseite gelenkt. Vermutlich dauert es deswegen so lange? Von den nahezu 50.000 indexierbaren Inhalten hat Google auch erst ca. 9.000 wieder im Index unter der neuen Domain. Vermutlich dauert es also einfach noch eine Weile.

    Ich bin und war auch auf dem Stand, dass die Links die auf Unterseiten zeigen (in Foren somit Themen) grundsätzlich auch root pushen dürften. Ist das nicht mehr so? Ich stamme noch aus der SEO-Zeit, als Nischenseiten gerade "In" geworden sind. ^^

  • Natürlich helfen die auch dem Root, aber ahrefs wird das ganz sicher anders bewerten. Also 100 Links auf Root und 100 identische Links auf eine Unterseite wird sehr sicher einen anderen DR ergeben. Das müsstest Du aber ahrefs fragen.

    Und ansonsten, ja, abwarten. Die müssen ja alles erst mal finden. Und da weiß ich nun nicht, wie die das genau machen und in welchen Intervallen bereits bekannte Quellen neu geprüft werden. Ich weiß hier nur aus meinen Logs, dass die teils ziemlich brachial spidern, aber eben nicht direkt eine bekannte Quelle, sondern alles, um neue Links zu finden. Deine Links sind aber so gesehen nicht neu. Die Frage ist da also eher, wie oft prüfen die erneut.

    Das was Du da mit der htaccess machtest, alles auf einen Schlag umleiten, das macht ahrefs ja nicht, die prüfen Link für Link, das kann dauern.

    Wegen Google: Ich habe letztes Jahr im Juli eine Domain genauso umgezogen. Von den neuen Zielen hat Google bis heute auch erst ca. 60%. Bei den anderen 40% sind die alten im Index, die neuen kennt Google angeblich nicht. Und das war auch eine Domain mit ca. 65.000 Seiten.

    Wenn ein Mensch nicht um dich kämpft, hat er nur gewartet, dass du gehst. ;(

  • Wegen Google: Ich habe letztes Jahr im Juli eine Domain genauso umgezogen. Von den neuen Zielen hat Google bis heute auch erst ca. 60%. Bei den anderen 40% sind die alten im Index, die neuen kennt Google angeblich nicht. Und das war auch eine Domain mit ca. 65.000 Seiten.

    Zunächst hat Google auch nur die Dinge gecrawlt, die nicht älter als 365 Tage sind. Das ist nämlich eine Standardeinstellung bei Woltlab Burning Board.

    Das habe ich vor wenigen Tagen umgestellt und deaktiviert. Seitdem ist Google äußerst fleißig.

  • Dein Problem ist, dass deine Weiterleitung aus

    https://www.newworld-forum.de/wiki/entry/112-fisch/

    https://www.newworld-forum.de/board/50-computer-hardware/

    https://www.newworld-forum.de/thread/1653-sc…ild-einhandaxt/

    usw.

    das macht:

    https://mmo-forum.de/board/66-new-world-forum/

    Je Forum leitet der 301 alles von der Domain auf den jeweiligen Subordner.

    Google folgt der Weiterleitung zwar, bewertet es aber nicht. Auch die externe Linkpower wird entwertet. Kann man nicht gut finden, hilft das Problem zu lösen aber nicht.

    Sauber wäre es absolut alles korrekt weiterzuleiten so:

    https://www.newworld-forum.de/thread/1653-sc…ild-einhandaxt/ auf:

    https://mmo-forum.de/thread/1653-schwert-schild-einhandaxt/

    Was jetzt nicht so schwer aussieht. In diesem Szenario waren alle neuen Seiten binnen 2 Tagen bei mir im Index und nach einer Woche die alten aus dem Index.

    Wenn du Zeit hast, reicht es auch, die Unterseiten, die mit externen Links versorgt worden sind, wieder auf die korrekten Unterseiten weiterzuleiten. So hast du nach 2 Jahren wieder annähernd die gleiche Linkstärke, wie vorher.

    Dein aktuelles Vorgehen ist mit einer der Worstcase Szenarien im Weiterleitungsjungle. Schlimmer ist eigentlich nur ein 302.

    Mit den Webmastertools von Google wärst du am nächsten dran, mMn benötigt man kein ahref mehr.

  • Leider weiß ich nicht, wie ich das umsetzen kann. Denn genau das war ja das Problem. Und der Gedanke, dass Woltlab bei einem Import bestehender Installationen alle ID´s neu verteilt... ;)

    Es geht also "nur" um Anpassungen in der .htaccess? Diese müsste ja nun jeweils im root der alten Installationen eingestellt werden. Aber mit welchem Inhalt?

  • Ach herrje, Danke Frank-L. Da prüft man einmal nicht wirklich was, sondern liest nur und glaubt, was da steht, und dann das....

    Logisch, Du leitest alles an eine Seite weiter. Hatte das zwar gesehen, aber dann gedacht, das soll so sein.....

    Wenn Du nur die Domain geändert hast und die URIs ansonsten gleich sind, dann so:

    Apache Configuration
    RewriteEngine On
    RewriteRule ^(.*)$ https://mmo-forum.de/$1 [L,R=301]

    Das (.*) ist der Platzhalter am Anfang, der auf alles matched, also auf Root / oder auch auf Unterordner wie /thread/keine-ahnung-was/12345/. Das $1 am Ende ist nix anderes als die Anweisung, dass der das, was er vorne beim (.*) gefunden hat, hinten anhängen soll.

    Wobei das aber eben nur geht, wenn alles an der URL gleich ist, nur die Domain anders. Das von Frank oben verlinkte Wiki 112-fisch ist aber z.B. am Ziel eine andere URL, der ist es nämlich 102-fisch. Eine URI "112-fisch" gibt es auf der neuen Domain nicht.

    Könnte also kompliziert werden, wenn das wirklich 7 Domänen sind, die da nun zusammengezogen wurden. Fakt ist, Du brauchst für jede Quelle das entsprechende Ziel. Zur Not musste alles, was halbwegs wichtig ist, einzeln umleiten.

    Das Wiki scheint schon mal gänzlich anderes zu sein. Andere IDs und andere Ordner. Einmal /wiki/entry/ und einmal wiki-entry. Das wäre noch nicht mal schlimm, das geht automatisiert, aber die geänderten IDs nicht.

    In Sachen Wicki musste dem also jeweils sagen

    Apache Configuration
    RewriteRule ^/alter-pfad/$ https://mmo-forum.de/neuer-pfad/ [L,R=301]

    Also ohne (.*) und ohne $1, denn automatisiert geht das da nicht. Automatisiert geht nur da, wo alles identisch ist, bis auf die Domain selbst.

    Bei den getesten Threads hingegen geht es, aber nur die, die ich auf die Schnelle gefunden habe. Also ein "/thread/3288-rp-pyrandia/" gibt es auf der alten Domain und auf der Neuen.

    Also musste quasi schon mal die Anweisungen insofern abändern, dass

    Wenn ein Mensch nicht um dich kämpft, hat er nur gewartet, dass du gehst. ;(

  • Ich habs mir mal angesehen. Während die New World IDs noch zu großen Teilen die selben sind, sind die IDs von z.B. Genshin Impact nicht mehr die gleichen. Da wäre es doch vermutlich besser, doch wieder auf die Startseite mmo-forum.de zu verlinken, stattdessen erhält man dort nämlich nun "Seite nicht gefunden". Und bevor man Google zu dieser Fehlerseite schickt, leitet man doch vermutlich besser auf die Startseite um?

    Was müsste ich denn im Code oben ersetzen, damit man bei allen Seiten, die nicht erfasst werden auf die Startseite umleitet?

  • Klar, daher sagte ich oben ja, die Ziele müssen passen. Ein 404 sollte da also nicht kommen. Das 1zu1 umzuleiten macht nur dann sind, wenn Du vorher alles, was nicht 1zu1 geht, also alles, das ein falsches Ziel hätte oder eben einen 404, vorher manuell umleitest.

    Alle Seiten die nicht erfasst werden.....

    Die htaccess kennt in dem Sinne kein "nicht erfasst", denn sie kennt die Ziele ja nicht.... "nicht erfasst" bedeutet hier dann nur, "was vorher nicht manuell definiert wurde".

    Das ist quasi das gleiche wie Du anfangs hattest, nur dass vor Deiner damaligen Rule eben nun die manuellen kommen.

    Die werden ja zeilenweise abgearbeitet. Was hier also die ersten drei nicht greifen, dann greift die letzte und die leitet nun, in dem Fall, immer an die "/board/66-new-world-forum/" um. Es zählt also der erste Treffer einer Rule. Wenn es einen gibt, dann wird die Abbarbeitung beendet. Ansonsten geht es so lange durch, bis was passendes gefunden wird oder eben die htaccess am Ende ist. Die letzte, die mit dem "^(.*)$" greift immer, wenn die Abarbeitung denn bis dahin kommt. Das ist mehr oder weniger ein Catch-All. Du musst also vorher so viel wie möglich definieren, also alte URL und neues Ziel, damit so viel wie möglich an das richtige Ziel geht. Am besten alles.

    In dem Code oben wäre es also, wenn einer "/wiki/entry/76-fischen/" aufruft, ein Treffer bei Zeile 7. Da ist dann Weiterleitung und Abbruch. Gäbe es den Treffer nicht, dann würde die Abarbeitung weiter laufen bis Zeile 13 und das ist dann der Catch-All.

    Und letztendlich sind das sehr sehr viele Umleitungen. Das sind nicht nur die Foren, sondern auch die Themen, die Pagination von Unterforen und Themen, die User-Seiten, Wiki, andere Dinge etc.

    Das Forum hier hat, wenn ich mich nicht irre, wegen der damaligen Systemumstellung an die 2000 Rules, weil eben auch alt und neu unterschiedliche URIs und vor allem IDs hatten.

    Im Grunde hast Du nur eine sinnvolle Möglichkeit.

    Hol Dir eine Sitemap der alten Domain und eine der neuen. Importiere beide nach Excel, damit die jeweil sin einer Spalte sind. Alte links, neue rechts. Dann sortiere und verschiebe so lange durch, bis in beiden Spalten jeweils das entsprechende Gegenstück von alt und neu steht. Leere Fehler in der neuen Spalte sind manuell mit Werten zu füllen.

    Dann haste eine Tabelle, mit einer URL links und einer URL rechts daneben. Also pro Zeile dann Quelle und Ziel. Daraus baust Du Dir dann die Rules, denn die sind ja nichts anderes

    RewriteRule ^QUELLE$ https://mmo-forum.de/ZIEL [L,R=301]

    Wobei halt Quelle ohne Domain, sondern nur der Pfad selbst. Wobei das das kleinste Problem ist. Editor der Wahl, einfach Suchen und Ersetzen. Der Rest dann genauso. Ans Ende jeweils ein [L,R=301], an den Anfang das RewriteRule ^ und dazwischen (ans Ende der Quelle) ein $. Wie gesagt, das ist doofes Suchen und Ersetzen. Ein vernünftiger Editor macht das in 20 Sekunden. Die Hauptarbeit ist die Liste zu erstellen, was von wo nach wo geht, also alt -> neu.

    Wenn ein Mensch nicht um dich kämpft, hat er nur gewartet, dass du gehst. ;(

  • Apache Configuration
    RewriteEngine On
    RewriteRule ^/wiki/entry/112-fisch/$ https://mmo-forum.de/wiki-entry/102-fisch/ [L,R=301]
    RewriteRule ^/wiki/entry/76-fischen/$ https://mmo-forum.de/wiki-entry/72-fischen/ [L,R=301]
    RewriteRule ^/wiki/lexicon/18-waffen/$ https://mmo-forum.de/wiki/24-waffen/ [L,R=301]
    RewriteRule ^(.*)$ https://mmo-forum.de/$1 [L,R=301]
    RewriteRule ^(.*)$ https://mmo-forum.de/board/66-new-world-forum/ [L,R=301]

    So dürfte es auch gehen, oder?

    Apache Configuration
    RewriteRule ^/wiki/entry/112-fisch/$ https://mmo-forum.de/wiki-entry/102-fisch/ [L,R=301]
    RewriteRule ^/wiki/entry/76-fischen/$ https://mmo-forum.de/wiki-entry/72-fischen/ [L,R=301]
    RewriteRule ^/wiki/lexicon/18-waffen/$ https://mmo-forum.de/wiki/24-waffen/ [L,R=301]

    Die Umleitungen funktionieren leider nicht. Seite nicht gefunden.

    Apache Configuration
    RewriteRule ^/community/article/10-new-world-map-karte-mit-filtern/$ https://mmo-forum.de/artikel/8-new-world-map-karte-mit-filtern/ [L,R=301]

    Leitet z.B. trotzdem zu article 10, obwohl es ja nun zu 8 leiten müsste....

    Code
    Redirect 301 /community/article/11-new-world-skilltrainer/ https://mmo-forum.de/artikel/9-new-world-skilltrainer/

    Auch der Redirect 301 von der vorherigen Adresse http://newworld-forum.de/xxx funktioniert nicht.

    2 Mal editiert, zuletzt von DreMa (24. Mai 2023 um 01:25)

  • Hol Dir eine Sitemap der alten Domain und eine der neuen. Importiere beide nach Excel, damit die jeweil sin einer Spalte sind. Alte links, neue rechts. Dann sortiere und verschiebe so lange durch, bis in beiden Spalten jeweils das entsprechende Gegenstück von alt und neu steht. Leere Fehler in der neuen Spalte sind manuell mit Werten zu füllen.


    Dann haste eine Tabelle, mit einer URL links und einer URL rechts daneben. Also pro Zeile dann Quelle und Ziel. Daraus baust Du Dir dann die Rules, denn die sind ja nichts anderes

    Bei der Vorgehensweise müsste ich 6.410 Themen händisch überprüfen ^^ Und dann hätte ich 1 von 7 Foren durch..... und das selbe ja auch nochmal für Beiträge, Wiki, Galerie User. Nahezu 50.000 Seiten händisch prüfen?


    Ich habe es jetzt erstmal so gelöst für die überschaubare Anzahl an Artikeln:

    Ist das so richtig? ^^ Weiterleitung funktioniert jedenfalls und zeigt von den alten Einträgen auf die neuen. ^^

    Einmal editiert, zuletzt von DreMa (24. Mai 2023 um 04:11)

  • Guten Morgen

    Ich bin ein gutes Stück weitergekommen. Danke dafür schon einmal! :)

    Leider führen trotzdem manche Seiten zu einem Seite nicht gefunden.

    Vor allem Zeile 22, 23, 45, 46 funktionieren aus mir unerklärlichen Gründen nicht.

  • Also erst mal oben Dein Post #11. Dein erster Code kann nicht gehen bzw. nur teilweise, denn beachte Zeile für Zeile. 2, 3, und 4 sind spezielle BEdingungen, die nur greifen, wenn die URL exakt so ist, wie da angegeben. Wenn von den dreien keine zutrifft, dann greift immer Zeile 5, da diese ein Catch-All (.*) ist. Sprich, Zeile 6 wird niemals erreicht.

    Prinzipiell. Die meisten Probleme, die Leute mit den Rules haben, vor allem, wenn es sehr viele sind, ist, dass die Reihenfolge falsch ist. Die Leute meinen, Zeile X sollte was spezielles machen, aber der Ablauf kommt erst garnicht dahin, weil eine Zeile weiter vorne schon was anderes macht.

    Noch komplizierter wird es, wenn "RewriteCond" ins spiel kommen. In Deinem Fall eher egal, denn es ist immer nur eine Cond und die gleiche. In dem Fall also immer. "Führe die nachfolgende Rule nur aus, wenn die URL keinen Query-String hat". Die Conds sind Bedingungen, die nur auf die nächste Rule wirken. Treffen die Conds zu, dann wird die nächste Rule geprüft, ob sie zutrifft oder nicht. Ist die Conds nicht zutreffend, dann wird die nächste Rule immer übersprungen. So kann man den Ablauf also etwas steuern.

    Deine Rules im letzten Post. In den Bedingungen musst Du keine Bindestriche maskieren. Also ein

    ^community/article/27\-duelle\-in\-new\-world/$

    ist nicht nötig, es reicht ein

    ^community/article/27-duelle-in-new-world/$

    Es gibt Zeichen, die maskiert werden müssen. Das ist z.B. der Stern, der Punkt, das Plus, Klammern. denn das sind Zeichen, die auch in der normalen Regex vorkommen können. Also z.B. in (.*). Die haben besondere Funktionen. Ein Punkt . ist unmaskiert nicht einfach ein Punkt, sondern bedeutet "ein beliebiges Zeichen". Ein Stern ist kein Stern, sondern bedeutet "keines oder beliebig viele Zeichen". In der Kombi als .* dann eben "keines oder beliebig viele Zeichen, egal was für welche".

    Die letzten Rules aus dem letzen Post sehen eigentlich gut aus. Wirke Problem sehe ich da nicht, vor allem nicht bei den Zeilen 22, 23, 45, 46.

    Probleme könnten aber die UTF8 machen, also die, wo in der Quelle oder im Ziel etwas vorkommt wie "%C3%BCb", denn % ist eine interne Referenz. Diese UTF-8 Dinger muss man teilweise anders schreiben, aber meist auch testen, welche Version funktioniert.

    Also welche Rules von den letztgenannten gehen denn genau nicht?

    Wenn ein Mensch nicht um dich kämpft, hat er nur gewartet, dass du gehst. ;(

  • Die Rule da ist z.B. so eine.....

    Apache Configuration
    RewriteRule ^wiki/lexicon/13-r%C3%BCstungen/$ https://mmo-forum.de/wiki/19-r%C3%BCstungen/ [R=301,L]

    Du willst also von "wiki/lexicon/13-r%C3%BCstungen/" nach "https://mmo-forum.de/wiki/19-r%C3%BCstungen/"

    Er leitet aber weiter an "https://mmo-forum.de/wiki/lexicon/13-r%c3%bcstungen/", macht also eine 1zu1-Weiterleitung. Er hat also die Rule ignoriert, weil kein Treffer und führt dann am Ende die Catch-All aus. Kein Treffer heißt hier, das "^wiki/lexicon/13-r%C3%BCstungen/$" war schon mal falsch. Ziel ist hier noch gar nicht versucht worden. Und das Problem ist hier definitiv das "%".

    Vorab, es kommt hier auch auf die Schreibweise an. Ein %C3%BC ist ein großes Ü, ein %c3%bc aber ein kleines "ü".

    Versuche also mal die Rule da:

    RewriteRule ^wiki/lexicon/13-rüstungen/$ https://mmo-forum.de/wiki/19-rüstungen/ [R=301,L,NC]

    Geändert ist da nun, dass die Umlaute direkt verwendet werden und nicht kodiert und am Ende noch das Flag NC angehängt wurde. Das NC sorgt nur dafür, dass es egal ist, ob Groß- oder Kleinschreibung (NoCase). Denn bei den Kodierungen ist das nicht so ganz einfach. Selbst die Browser machen das unterschiedlich. Mal machen die aus einem ü ein %C3%BC, manchmal aber auch ein %c3%bc.

    Die interne Umsetzung der Sonderzeichen überlässt Du so erst mal dem Apache selbst, also gibt dem in Quelle und Ziel einfach das entsprechende "ü". Der kodiert von alleine, wenn der so arbeitet wie die meisten. Der schreibt also intern bei der Bearbeitung das ü selbst um in UTF-8, wenn er so entsprechend konfiguriert ist. Es kann aber auch passieren, dass der nach ISO (Windows-Zeichensatz) umschreibt, dann muss ein anderer Versuch her.

    Wenn das so nicht geht, dann muss man etwas testen. Gibt dann auch noch "NE" (NoEscape), denn das ist genau das, was der Apache eigentlich mit einem % macht. Es gibt da drei oder vier Kombinationen. Wenn man mal eine hat, die geht, dann gehen alle anderen mit Sonderzeichen auch damit.

    Wenn ein Mensch nicht um dich kämpft, hat er nur gewartet, dass du gehst. ;(

  • Huhu, Wiki, Artikel und IDs (auch bei weiteren Foren) konnte ich soweit manuell weiterleiten.

    Aufgerufen werden musste vorher immer nur

    Code
    https://www.elderscrolls-blades.de/thread/48/ - verlinkt nicht
    https://www.elderscrolls-blades.de/thread/48-wie-weit-seid-ihr-bisher-gekommen/

    jetzt muss aber immer komplett die ganze URL ausgeschrieben werden. Gibt es dafür einen Workaround?

  • Schreibe bitte mal Deine komplette htaccess dazu von der "elderscrolls-blades.de", da muss ja auch noch mehr drinnen sein.

    Das mit der "ID weiterleiten" kommt ja eigentlich von WBB. Also das versucht, wenn es eine ID in der URL hat, den Post dazu zu finden.

    Z.B. bei

    Code
    https://mmo-forum.de/board/76-geschichte/
    https://mmo-forum.de/board/76-xxxxx/
    https://mmo-forum.de/board/76

    Man landet da immer immer am richtigen Ziel, weil WBB intern gar nicht mit der leserlichen URL "-geschichte" arbeitet, sondern einfach nur mit der ID. Und wenn dann die von WBB zusammengebaute URI nicht mit dem Request übereinstimmt, dann leitet es alleine weiter.

    Ist hier im Forum genauso. Dieser Thread hier hat ja

    Code
    https://seo-nw.de/forum/thread/125178-ahrefs-backlink-checker-%C3%BCbernimmt-domain-rating-der-alten-website-nicht/

    aber mit einem doofen

    Code
    https://seo-nw.de/forum/thread/125178-foo-bar/

    landeste auch an der richtigen Stelle, weil die ID weiterhin stimmt. Dem WBB reicht hier schlicht die Info "thread = 125178" und oben schlicht "board = 76"

    Bei Dir geht das oben noch mit der "geschichte". Wenn das bei anderen Dingen nicht mehr geht, dann kann das an der Catch-All liegen, denn die leitet ja an eine feste URI weiter.

    In Deinem oben genannten Fall leitet die https://www.elderscrolls-blades.de/thread/48/ an die https://mmo-forum.de/board/1-the-elder-scrolls-blades/ weiter und genau das muss irgendwo her kommen. Also irgendeine Rule matched da und gibt vor, an die "1-the-elder-scrolls-blades" zu leiten.

    Wobei es der Catch-All, also so wie er oben ist, nicht wirklich sein kann. Bei dem würde folgendes passieren.

    RewriteRule ^(.*)$ https://mmo-forum.de/$1 [L,R=301]

    Wenn eine Anfrage nach "/thread/48" kommt, dann leitet die Rule an "https://mmo-forum.de/thread/48" weiter. Dann kommt WBB ins Spiel, sieht die ID und fragt in der Datenbank den Thread mit der ID 48 ab. Dann leitet eigentlich WBB an das richtige Ziel mit "sprechender" URI.

    Wobei Du natürlich aufpassen musst. Das mit der "Kurzform" per ID geht eigentlich nur im neuen Zielforum. Über das alte wird das nicht sauber gehen, denn woher soll da denn einer wissen, wenn da eine "48" kommt, welcher Thread da gemeint ist. Die 48 wird es sicherlich ja vorher bei den Einzelforen mehrfach gegeben haben und nun hat nur noch einer die 48, die anderen haben neue IDs.

    Wenn ein Mensch nicht um dich kämpft, hat er nur gewartet, dass du gehst. ;(

  • Huhu, Wiki, Artikel und IDs (auch bei weiteren Foren) konnte ich soweit manuell weiterleiten.

    Aufgerufen werden musste vorher immer nur

    Code
    https://www.elderscrolls-blades.de/thread/48/ - verlinkt nicht
    https://www.elderscrolls-blades.de/thread/48-wie-weit-seid-ihr-bisher-gekommen/

    jetzt muss aber immer komplett die ganze URL ausgeschrieben werden. Gibt es dafür einen Workaround?

    Hatte das früher mit Xenu gemacht, der hat die Alte Domain gecrawled und in Listen die ganzen Urls ausgegeben und nach der Umstellung hatte ich die Neue Domain damit gecrawled und über Excel die jeweiligen zugehörigen URLs mit der Verkettenfunktion zu einer Rewriterule zusammengefügt.

    Einmal editiert, zuletzt von Frank-L (24. Mai 2023 um 18:50)

  • Ja, das ist die Catch-All. Die reine kurze URI mit /thread/48 wird oben in den ganzen Rules ja nicht getroffen, also greift die Catch-All.

    Bei der sagst Du da nun aber nicht, leite 1zu1 weiter, also ID 48 zu ID 48, sondern fix alles an ID 1. Somit hat WBB dann eine gültige URI, nämlich die "/board/1-the-elder-scrolls-blades/". Das WBB bekommt von der angefragten "thread/48" ja gar nichts mit, das setzt ja die htaccess vorher um.

    Du musst das also entweder so lassen und alles, was nicht manuell weitergeleitet wird, geht an EINE bestimmte Seite

    oder Du machst das mit dem Catch-All wie vorher mit dem Ziel http://domain.de/$1, dann ist es wieder eine 1zu1-Weiterleitung. Aber eben mit dem Problem, dass es dann durchaus 404 geben kann. Auch ist nicht sicher, ob die dann abgefragte ID 48 auch die ist, die Du erwartest.

    Wenn ein Mensch nicht um dich kämpft, hat er nur gewartet, dass du gehst. ;(