adsense und joom 1.7

  • versthe des ned, warum die des überhaupt gemacht haben. Wieso nimmt der Editor im Contentbereich keinen adsense code mehr an.


    Und zu den Modulen, hab eines installiert auf ner anderen Joomla1.7 Seite, funktioniert dort, auf der neuen die ich eben installiert hab, dann ned?


    Was funktioniert in dem 1.7er überhaupt noch, echt.

  • Also ich hab ausgewiesenermassen keinen Schimmer von Joomla, aber warum nimmste kein "AdInjector"-Modul? Das sollte es doch auch für Jommla geben, oder?

    Wer zuerst "Datenschutz" sagt, hat verloren.

  • Doch, Joomla 1.7 nimmt Adsense an.
    Guck mal hier:*** Link veraltet ***
    Ist Joomla 1.7 UND Adsense.. OHNE Plugin. Im Artikel Adsense-Code direkt,
    rechts ist ein Benutzer-Modul (unter Modulen) und Adsense Code


    Joomla 1.7 ist nur mehr auf Sicherheit aus und filtert HTML-Code.
    Du musst unter "Beiträge" -> Optionen (rechts oben) - es kommt ein Popup
    hier auf Textfilter klicken und dann auf Super Benutzer (andere habe ich nicht getestet)
    Filterverfahren=keine Filterung ->schliessen
    Das ist die grundsätzliche Einstellung. Auf Dauer.


    Dann auf Site->Konfiguration:
    Editor: Kein Editor (Editor ausschalten)
    Jetzt kannst du deine Texte (Beiträge bearbeiten, aber im HTML-Code, WYSIWIG ist ausgeschaltet)
    und jetzt gibst du deinen Adsense-Code ein. Danach speichern.


    Jetzt kannst du wieder zurück zu "Site->Konfiguration:" und den Editor wieder einschalten.
    Den Beitrag darfst du mit dem Editor danach nicht mehr bearbeiten,
    weil der HTML-Code wieder herausgefiltert wird (nochmal, das ist eine Vorsichtsmassnahme seitens Joomla).


    Wenn du normal schreibst, und kurz den Editor abschaltest (editor an/aus unterhalb des Eingabefensters)
    geht es nicht. Sobald du den Editor wieder einschaltest ist der HTML-Code wieder herausgefiltert.
    Es geht nur auf diese Weise wie ich es oben beschrieben habe:
    1. Globale Einstellung: den Super Benutzer nicht Filtern (macht man nur ein einziges mal, nicht jedes mal)
    2. Site-Konfiguration: Editor aus (jedes mal)
    3. Beitrag bearbeiten, Code eingeben, Speichern (jedes mal)
    4. Site-Konfiguration: Editor wieder einschalten (jedes mal)
    5. Beitrag nicht mehr bearbeiten, sonst wird wieder gefiltert.


    Andere Möglichkeit ist, vorgehen wie beschrieben, in alle fertigen Beiträgen Adsense einfügen
    Editor wieder an.

  • dragobert


    naja, hab dies gerade gelesen und bedanke mich für Deine Info! Werd dies morgen ausprobiren. Aber hab ein Problem was es bisher NIE gegeben hat. Bin draufgekommen das das "Template" schuld ist an der adsense Miesere. Kein Spaß. Hab jetzt 3 Seiten auf JOOM1.7 Upgegradet. Einer mein Bier Blog, dort funktioniert adsense. Dan zwei andere, bei einer funktioniert adsense, ohne Hindernisse, , nur gerade bei einer meiner stärksten Seiten dort eben nicht. Hab zwei adsense Module hochgeladen (eine von Alex empfohlen) kann machen was ich will, dort funkt adsense nicht. Hab sowas noch nie erlebt das ein Template selbst adsense blockt, was anderes kann es nicht sein. Weil alle 3 Joomla 1.7 Installationen genau gleich, fast die gleichen Komponenten, einziger Unterschied - das Template.


    snowdog

  • An den Templates kann es wirklich liegen. Bei etlichen Templates habe ich das Problem
    das Listen nicht formatiert werden, also kein <ul>, <li> usw. Aber nur auf dem Webspace.
    Daheim auf zwei Servern nicht. Da funzt alles normal.
    (aber da ist ja auch das allerneueste PHP und das allerneueste MySql).


    Das gleiche mit Slideshows auf der Startseite. Laut Beschreibung
    sollte die Slideshow nur auf der Home zu finden sein.
    Bei mir auf dem Server (internet) definitiv nicht. Da ist sie auf jeder Seite. Nur Abschalten hilft.
    In meinem Fall hiess es aber passendes (bei mir funktionierendes) Template finden.

  • Hi Dragobert!


    Naja, geht im Prinzip ums Template - das passende. Und des war das einzig passende, wollt die Seite ja gar nicht ändern. Aber dachte dann is vielleicht doch besser. Aber kapier ned wie ein Template Code adsense verweigern kann. Hab des adsense in zwei Modulen und keines geht. Viel gedacht habne sich die ned dabei, obwohls ein templates von ner bekannten Agentur ist, die auf Joomla Hosting spezialisiert sind.


    snowdog

  • Wie schon gesagt, die erwähnten Problem hatte ich nur mit den Servern auf dem Webspace.
    Hier daheim auf meinen Servern, mit den neuesten PHP und MYSQL hatte ich diese Probleme nicht.


    Ein Problem hatte ich wo MYSQL eine Rolle spielte. Auf dem Ersten Blick hat es mit der Datenbank nix zu tun.
    Es ging um manche Funktionen die nach der Installation nicht gingen obwohl alles o.k ist.
    Dann las ich einen Tipp, man solle einfach die Datenbank exportieren, leeren, dann wieder importieren.
    Und schon lief Joomla super. Wohlgemerkt es ging nicht um Inhalt, Kategorien oder sonstwas,
    sondern um das Laufen von Joomla selbst.


    Die einzige Erklärung die ich nach einigen Tagen Recherche fand ist, dass eben PHP- und MySQL Version
    eine wichtige Rolle spielen. Bei meinem Provider bedeutet das, Joomla läuft, aber die PHP-Version ist ein
    Hauch unterhalb von dem was Joomla 1.7 erwartet. Aber es läuft trotzdem. Bis auf das, das manche Templates
    nicht sauber laufen. Auch beim Beiträge darstellen.


    Bei einem Server musste ich Joomla mehrfach neu istallieren, und jede verlief komischerweise
    anders, bei absolut gleichen Schritten. Extra Schritt für Schritt aufgeschrieben und "Logbuch"
    auf dem Schreibtisch geführt, um das Verhalten von Server und Joomla irgendwie nachzuvollziehen.

  • Zitat von dragobert;12637

    Hier übrigens ein Link zur Seite, der mir zeigte wie man Adsense in Joomla 1.7 einbaut
    *** Link veraltet ***


    super danke - sieh ich mir an

  • Zitat von dragobert;12636

    ...


    Die einzige Erklärung die ich nach einigen Tagen Recherche fand ist, dass eben PHP- und MySQL Version
    eine wichtige Rolle spielen. Bei meinem Provider bedeutet das, Joomla läuft, aber die PHP-Version ist ein
    Hauch unterhalb von dem was Joomla 1.7 erwartet. .


    Also am Provider kanns ned liegen. Den kennen wir beide und der hat spezielle Joomla Hostiung und selbst seine Seiten in Joom1.7 laufen.
    Deswegen hab ich das eigentlich sofort ausgeschlossen, das es daran liegen könnte.


    Naja, mal abwarten. Aber Danke auf alle Fälle.


    snowdog