Probleme mit der Navigation auf unserer Webseite

  • Hallo Zusammen ich bin der Frank und neu hier bei Euch. Ich habe gestern kurz mit Alex gesprochen wegen dem Problem der Navigation auf unserer Seite *** URL-Filter ****. Ich habe oben, ganz oben eine Tabelle eingebaut in dem die links aufgeführt sind. Das klappt auch soweit aber die Skalierung treibt mich in den Wahnsinn :D. Das ganze ist so aufgebaut, eigentlich total einfach aber wie geschrieben die Skalierung passt nicht genau.


    HTML Code:


    <table border="1" align="center" width="980px">
    <td><div id="navcontainer">
    <ul id="navlist">
    <li id="active"><span title="ne0DataSolution IT-Engineering die Schmiede f&uuml;r System und Netzwerk"><a href="https://beispiel.rocks/beispiel.rocks/www.ne0datasolution.ch" id="current">Schmiede</a></li>
    <li><span title="ne0DataSolution IT-Engineering - Systemtechnik - Serverl&ouml;sungen f&uuml;r Ihre IT-Infrastruktur"><a href="https://beispiel.rocks/beispiel.rocks/www.ne0datasolution.ch/systemtechnik.html">Systemtechnik</a></li>
    <li><span title="ne0DataSolution IT-Engineering - Netzwerktechnik f&uuml;r Ihre IT-Infrastruktur"><a href="https://beispiel.rocks/beispiel.rocks/www.ne0datasolution.ch/netzwerktechnik.html">Netzwerktechnik</a></li>
    <li><span title="ne0DataSolution IT-Engineering - Kontakt"><a href="https://beispiel.rocks/beispiel.rocks/172.16.8.5/index.php?option=com_content&view=article&layout=edit&id=10">Kontakt</a></li>
    </ul>
    </div></td>
    </tr>
    </table>


    CSS Anweisungen:


    #navlist li
    {
    padding-left: 15px;
    font-family: "Verdana";
    font-size: 15px;
    display: inline;
    align="left";
    display:inline;
    }


    Hat jemand einen Rat für mich oder kann mir das perfekt machen?


    Lieben Dank


    Frank

  • P.S. Sagen kann ich aber schon mal, dass auf der Seite so einiges im argen ist... G+ ist falsch gesetzt, als "a" und nicht als "link". Twitter ist falsch, dann sind da </script> drinnen, die auch falsch sind. Wegen Deiner Navigation, die hockt auch noch im <head>-Bereich und nicht im <body>, am Ende auch wieder, da ist es nach <body>.


    Im Grunde ist bei der Seite die ganze HTML-Struktur zerschossen, würde erst mal anfangen, das zu bereinigen.


    <html>
    <head></head>
    <body></body>
    </html>

  • Macht auch nicht viel Sinn so, denn die vermeintlich korrekte Darstellung ist wohl reiner Zufall....


    Wenn schon der w3c im HEAD 51 Fehler findet (einige davon sind kein, das kann der auf Grund der anderen groben Fehler aber nicht erkennen), dann weiß man was los ist. Und w3c verweigert dann sogar den Dienst, das habe ich noch nie erlebt ;)


    "Cannot recover after last error. Any further errors will be ignored."


    *** Link veraltet ***

  • Hab ich gar nicht erst versucht. Aber hast Recht, hab ich auch noch nicht gesehen.


    Eigentlich wollte ich nur kurz nach der Tabelle schauen, weil mir die Existenz schon spanisch vorkommt, also völlig überflüssig scheint. Aber da biste mit neu stricken schneller.

  • Moin Frank,
    ja da musste nochmal ran. Dein Code stimmt da noch nicht...

    wenn etwas möglich erscheint mach ich das, wenn das nicht klappt gehts ans unmögliche und ansonsten das undenkbare.
    Ich denke, also BING ich!


    Support 24h Bereitschaft 0163 2161604 - NUR Für Kunden von SEO NW!