Google Indexierung

  • Und damit es nicht langweilig wird. Wie schon mal vorher irgendwo erwähnt, indexiert Google Seiten mit falschen URLs. In dem Fall aber nicht nur falsche Pfadangaben, sondern falsche "DOMAIN"!.


    Ich nenne die beiden Domänen einfach mal "Hunde-Seite" und "Nordsee-Seite" und nutze als Beispiel eine Bildergalerie.



    Zu finden sind die Seiten bei der Suche nach "Hunde-Seite", alle Bilder sind indexiert. Die Seiten werden organisch als Treffer gelistet, enthalten aber einen Cache von "Nordsee-Seite". So, der Witz an der Sache ist, dass es die Seiten gar nicht bei beiden Portalen gibt. Und wenn es doch mal ein Ferienobjekt in beiden geben sollte, dann ist eines von beiden noindex. Ebenso sind die URLs als auch Seiten-Titel unterschiedlich.


    URL z.B. Hunde-Seite: /unterkunft-ID/fotogalerie/

    Nordsee-Seite: /unterkunft/ID/fotogalerie/


    Die Schreibweise mit dem Bindestrich gibt es nur bei der Hunde-Seite, bei keiner anderen. Es reagiert auch keine andere mit einer Weiterleitung oder so darauf. Die gibt es wirklich nur bei Hund. Und wenn ich meine, die Objekte gibt es nicht, dann meine ich, auch die Seite /unterkunft-ID/ als Linkgebende Seite für die Galerie gibt es nicht. Schlicht, das ganze Ferienobjekt existiert auf dem Portal nicht.


    Und was macht Gooogle? Ist dem völlig scheißegal. Auch der Canonical, der richtig ist, egal. Google nutzt seinen eigenen und der ist eben falsch.


    Im Bild oben. Das ist also ein Treffer, wenn man bei der "Hunde-Seite" sucht. Das Objekt ist aber auf der "Nordsee-Seite" gelistet. Das Bild selbst in der Ansicht stammt von der Nordsee-Seite, das Favicon daneben aber von der "Hund". Die erwähnte Domain ist wieder "Nordsee". Der Titel darunter ist von der "Nordsee", der Button rechts daneben ist mit "Hund" verlinkt (ergibt beim Klick entsprechend einen 404). Gleichzeitig ist dem aber ein Aria-Label hinterlegt mit "Nordsee-Seite besuchen".


    Was verflucht macht Google da also?


    Und das spiel geht noch weiter. Google folgt den Links, die auch im Cache sichtbar sind. Diese Links, die zur "Nordsee" gehören, folgt Google aber bei der "Hund". Entsprechend ist da auch fast alles falsch oder wirft Fehler.

  • Mmmh, einen Tag nach dem letzten Google Cache eine gut seit 2 Jahren unberührte Unterseite angepasst und nun rührt sich schon 14 Tage nichts. Sind ca. 10 neue darunterliegende neue Unterseiten hinzugekommen. Gerade Eine davon ist im Index. Gut, den Content sehe ich eher als minderwertig an. Aber trotzdem nervig, gerade bei dem Shop, der quasi täglich Veränderungen hat.

  • Google ist die Hölle aktuell, also eigentlich ja schon seit Ende 2021. Bei Alex ebenso. Erst tut sich gar nix, dann kommt nach etlichen Wochen ein ganzer Schlag in den Index und das dann mit einem "Cache" von vor etlichen Tagen.


    Hier bei mir auch. Gerade auch wie Du schreibst, wenn sich öfters was ändert.... Echt nervig. Bei mir betrifft das vor allem Angebote und Lastminute. Die sind nun mal bedingt durch den Fakt, dass es Angebote sind, zeitlich begrenzt. Bis Google die aber mal abruft sind die schon wieder weg. Der Witz dabei, wie gestern.... Gleich zwei Mails bekommen, Fehler im Abruf, die Seiten wären "noindex". Klar, sind sie nun auch, Google ruft die ja auch 6 Wochen zu spät ab. Witzig auch, eben "gesendete URL ist noindex". In der Sitemap waren die drinnen, vor 6 Wochen eben. Aber seit 4 Wochen nicht mehr, da weg.


    Die scheinen also die Sitemap abgerufen zu haben, die URL gefunden, 6 Wochen später gespidert und dann zu meinen. He, die gesendete URL ist noindex. Ja nee, das war sie damals halt nicht, dann aktuell aber schon.


    Und was auch ist, Google ignoriert mittlerweile einen Canonical komplett, auch wenn deren "Auswahl" völlig falsch ist. Sehe ich sehr gut bei meinem Kalender-System. Da gibt es ja fertigen HTML-Code zur Einbindung. Einige gehen dann her und binden den HTML-Code als Link ein. Schaut dann so in etwa aus und das, obwohl alles andere richtig ist, nur eben ein einziger Link falsch gesetzt ist:


    Alternative Seite mit richtigem kanonischen Tag


  • Also grade bei "Angeboten" war ich auch voll am abkacken :)

    Bis die im Index waren, hatte die schon jemand auf der Site gefunden und gekauft. Wochen später tauchte die URL dann unter "Fehlerseiten" auf, weil sie natürlich schon wieder gelöscht waren.

    Ich glaube, ich erstelle mir da jetzt einfach neue Seiten ala:
    Hier finden sie alle unsere Angebote für preisreduzierte Seidenschals aus Chiffon + [500 Worte SEO-Content].
    Und darunter verlinke ich dann auf die Artikel.

    So werden wenigstens die 50-60 Angebotsseiten mit dem SEO-Content im Index landen. Hoffe ich.

    Wer zuerst "Datenschutz" sagt, hat verloren.

  • Ja, so in etwa mache ich das teilweise nun auch, aber nur teilweise, da nicht überall umgestellt und teilweise, weil es nicht immer / überall geht. Es sind einfach zu viele Themenbereiche und alles variabel. Das können zwei Zielseiten sein, aber auch 50 oder 1000.


    Ansonsten ja, eine Übersichtsseite, wo alle Angebote erst mal sind. So als Hauptseite, die immer da ist. Das mag Google aber auch nicht sonderlich. Siehe oben "Alternative Seite mit richtigem kanonischen Tag". Google wählt dann teils eine der Unterseiten als eigenes canonisches Ziel aus, das es dann aber nicht mehr gibt. Sprich, Google nimmt nicht die Übersicht "Angebote am Bodensee", sondern ein einzelnes Angebot davon als Ziel. Das "einzelne" ist halt schnell wieder weg. Kann Tage da sein, Wochen, aber auch nur Stunden. Die Übersicht würde es viel länger geben, eventuell sogar das ganze Jahr, weil es ja immer wieder neue Angebote gibt, die dort gelistet werden.


    Und es hagelt dann Fehlermeldungen. Kann man auch machen, was man will. Entweder 404, oder soft 404 oder eben noindex. Hatte auch schon eine Zeit lang versucht, die nicht mehr vorhandenen Angebote per 301 und auch 302 weiterzuleiten. Ging für eine Hand voll gut, dann kam plötzlich für alles ein "soft 404".


    Aktuell bin ich so weit, dass auf einer Domain alle Angebotsseiten auf noindex sind und die nicht mehr in die Sitemap kommen. Mal sehen, was nun passiert.


    Gestern wurde es ganz witzig.... Google wählte mal wieder einen eigenen Canonical aus. Diesmal ist das aber anders. Die URL (nur Beispiel) war, /Unterkünfte/Deutschland/Bayern/Würzburg/. Google meint, richtig ist einfach nur "/Unterkünfte/Würzburg/". Die liegt Google sogar richtig, denn den Filter Deutschland oder Bayern braucht man nicht, gibt ja nur ein Würzburg. Diese URL baute Google aber selbst zusammen, die gibt es in der Kombi gar nicht. Ja, erreichbar ist sie, aber eben mit dem Canonical auf die richtige Version.


    So, komisch und besonders eben, weil Google genau bei der Seite den richtigen Canonical nimmt, aber..... Die Seite selbst gibt es nicht.... Die liefert schon immer einen 404, weil ich in Würzburg gar keine Objekte habe!

  • Ja, ich dachte, ich mach das so, dass ich die einzelnen Angebote dann einfach auf Noindex stelle.
    bzw. mit nofollow verlinke.

    Mir ist es lieber, ich weiß, dass die gar nicht indexiert werden und ich dafür keine Fehler ausgespuckt bekomme, als dass der Kunde dann auf meiner Fehlerseite landet und angepisst ist, weil da eben kein tolles Angebot ist, sondern nur ein "OUPS! Die Seite wurde verschoben oder gelöscht."

    Wer zuerst "Datenschutz" sagt, hat verloren.

  • Bei "nofollow" wäre ich auch etwas vorsichtig. Google hält sich eigentlich daran, aber nur eigentlich. Habe hier viele Seiten, die über ein Outbound-Script gehen. Die Links selbst per nofollow eingebunden sind. Das Outbound dann selbst auch noch und das Ziel per robots.txt gesperrt. Geht bei Google, kein Problem. Aber Bing ignoriert das und die rufen die Seiten auf. Sehe ich schön im Affiliate-System. Massig registrierte Zugriffe auf Produkte vom Partner, die von Bing ausgelöst wurden. Diese Zwischenseiten sind bei Bing sogar in Massen im Index. Nicht das Ziel selbst, aber die Zwischenseite, die ja nix tut als sperren und weiterleiten.


    Dauert dann nicht lang, dann ruft Google die URLs auch auf. Dann halt direkt und da ist dann kein nofollow mehr. Google landet dann beim Zwischenscript und bricht ab. Folge: Warnungen in der GSC.

  • So, mal wieder was dazu, auch wenn es keine neuen Erkenntnisse sind. Sind nur mehr weitere Fragen und sinnloses Zeug.... Meine "Geranien kaufen" ist seit Tagen "verschwunden". Hin und wieder kommt sie mal wieder, für Minuten oder Stunden, dann ist sie wieder weg. Wie heute. Ewig weg, dann gefühlt eine Stunde da, wieder weg.....


    Und ich frage mich, warum ausgerechnet immer meine Seite "verschwindet" und keine andere !?!? Die Seite wird auch nicht durch eine andere ersetzt oder so, nee, die ist einfach weg.


    Da war sie da:



    Nun ist sie wieder weg:



    Also einfach verschwunden und es gibt nur noch 9 Treffer auf Seite 1.

  • Ich verstehe Google nicht. Habe neue Produkte in den "Shop" aufgenommen, vor etwas mehr als einer Stunde. Die Shop-Seite wird nicht gefunden, zu nichts, keinen Text, kein Key, kein nichts. Eben wollte ich suchen, wo auf meiner Domain ein bestimmtes Wort vorkommt, damit ich das verlinken kann. Also site-Abfrage + Key. Ok, ein paar Treffer gefunden, eignen sich für einen Link. Dann erst bemerkt, dass der letzte Treffer der "Shop" ist mit eben genau den neuen Produkten. Also indexiert in weniger oder um eine Stunde.



    Also per Site-Abfrage + Key ist die Unterseite da, mit Site-Abfrage ohne Key nicht und mit nur "Key" oder "Text" auch nicht. Auch wenn Google was anderes behauptet, die Seite ist nicht auffindbar. Nicht nur für mich, auch für andere nicht. Ich bekomme in dem Fall für jeden Zugriff eine Mail und heute kamen ganze 2. Das war heute Vormittag, als sie mal kurz da war.


    Und das muss sogar noch schneller gegangen sein, denn auch neu sind grüne Häkchen in der Meta-Beschreibung. Die sind auch schon da.